Ubuntu?

M.Canales.es macana at macana-es.com
Wed Aug 1 12:17:30 PDT 2007


El Miércoles, 1 de Agosto de 2007 20:54, Dan Nicholson escribió:

> Manuel, I completely sympathize with the interest of tearing out
> compatibility code, but IMO jhalfs shouldn't exceed the LFS Host
> Requirements limits: coreutils-5.0 and tar-1.14. Or, if that's a
> problem, then jhalfs should probably ship its own version checking
> script to tell users that they'll need to update their utilities if
> necessary.

Current jhalfs-2.3 already checks for Tar-1.15 and Bash-3.0.

What is the minimum Coreutils version with md5sum support for stdin? My 
three-years-old system is using Coreutils-5.2.1 

> Another thing that would help in situations like this would be to make
> use of more make variables. For instance, unpack should be calling
> $(TAR) with a default of TAR = tar in the Makefile. Then if someone
> needs to override things, they can do it in a systematic way:
>
> make TAR=my-tar-wrapper MD5SUM=md5sum-that-handles-stdin

Might be a compromise, but I don't have time right now to try it.

-- 
Manuel Canales Esparcia
Usuario de LFS nº2886:       http://www.linuxfromscratch.org
LFS en castellano: http://www.escomposlinux.org/lfs-es http://www.lfs-es.info
TLDP-ES:                           http://es.tldp.org



More information about the alfs-discuss mailing list