paco svn breaks jhalfs-paco patch

Tor Olav Stava t-ol-sta at online.no
Thu Mar 23 00:21:50 PST 2006


david.rosal at upf.edu wrote:

>Hello Tor.
>
>Don't use paco SVN versions for your jhalfs-paco patch.
>In 20060319 and later the variables PACO_INCLUDE and PACO_EXCLUDE are not met.
>This is experimental stuff, and may or may not be enabled in 1.10.4 (opinions?).
>  
>
Note taken.
In my opinion the environment variables isn't really needed if it can be 
set in the config file or using command line parameters. I'm using env 
variables by old habit. I've got Paco 1.10.2 installed on my host 
system, and the LD_PRELOAD bails out if the variables isn't set in the 
environment (PACO_TMPFILE, PACO_INCLUDE and PACO_EXCLUDE). Same 
behaviour with 1.10.3, but Paco-svn-20060319 only requires PACO_TMPFILE set.
I don't see why it's necessary to set the variables, when there's a 
config file. But 1.10.2 wants the variables set even if it's already set 
in the config file.

>Of course you still can use either the command line options -I/-E or the
>INCLUDE/EXCLUDE options in the configuration file, but I think that you're using
>the environment variables in your patch...
>  
>
Yes, I'm using the env vars (see above), but it would be easy to change 
it to command line options. That would possibly be a better solution. I 
think I'll make that change..

>So I suggest you to use 1.10.3. It is not that buggy :-)
>The only problem is that paco allways logs the files that are created within the
>build directory of the package. Of course this may be annoying, but it won't
>break anything and a simple sed script will clean up the logs.
>  
>
That's the reason I skipped the 1.10.3 version. Using sed for cleaning 
up shouldn't be necessary, especially since I don't speak sed ;)
I tried downgrading to 1.10.2, but that caused some weird error with 
HLFS-uClibc install in chapter06. When I tried the svn version, 
everything seemed fine.

>Anyway, a patch for 1.10.3 that fixes this problem is on the way. I will post an
>announce here.
>  
>
Nice. I'll go back to 1.10.3 and do more test-runs, as I've noticed more 
bugs in my paco-patch :(


Tor Olav



More information about the alfs-discuss mailing list