new makefile.

George Boudreau georgeb at linuxfromscratch.org
Tue Aug 29 12:38:39 PDT 2006


M.Canales.es wrote:
> El Martes, 29 de Agosto de 2006 15:44, George Boudreau escribió:
>> Manuel,
>>
>>    The new makefile scheme will be delayed for a while. After I ran the
>> ICA tests last night I found the shell path, /tools/bin/sh, was hard
>> coded into many scripts. (This is not right) 
> 
> For LFS, that sha-bang is used in 062-creatingdirs and  063-createfiles. Both 
> must be run from inside the chroot and there is no /bin/{bash,sh} until after 
> 063-createfiles run.
> 
> What is the issue you found due using /tools/bin/sh on that two scripts?
   There is no problem with 062 and 063 scripts. When 'make' runs it 
looks for a script at /bin/sh which does not exist in chroot env before 
062 & 063 run. I had to manually create bin/bash and bin/sh links to 
satisfy the requirement. This also solved the problem of /tool/bin/sh 
being hard coded in some packages. (zless, zmore.. etc)
> 
>>    Problems still remain as I see references to
>> /tools/lib/gcc.....(debug symbols) inside the executables. I am trying
>> to find out if these artifacts also exist in the original code (1.0).
>> This may be normal as I did not see any comments in the lists..
> 
> If that /tools/lib/gcc..... aren't found in a 1.0 run (it should not be here, 
> i think) then maybe the issue it that the shell used to run the chroot build 
> step isn't actually using +h.
>
> Well, now trunk and experimental are sync. Fell free to commit that changes 
> and don't worry breaking the branch. 
>
   I will post my changes to experimental branch later this evening.





More information about the alfs-discuss mailing list