./blfs-parser problems

M.Canales.es manuel at linuxfromscratch.org
Mon Aug 14 13:35:42 PDT 2006


El Lunes, 14 de Agosto de 2006 22:03, Michiel Faber escribió:

> Can someone tell me which package i need to use jhalfs? And if i already
> have them, can someone tell me what is going wrong here and how to solve

The support to can build into chroot or on a fresh first booted LFS system 
hasn't been added yet. That will be made available inside the menuconfig 
interface when ready (i.e., it will install automatically all required 
dependencies in addition to the LFS packages)

One of the reasons is that the tool is yet under development and maybe some 
new dependencies will be added (or removed).

At this moment, the required packages are: 

svn to get/update the BLFS book XML sources 
libxml and libxslt to parse the XML files
a web browser to read the generated book
wget to fetch the packages and patches
sudo to build as normal user

But actually only wget need be instaled into the chroot if you are building 
yet from the host. You can run the jhalfs scripts from the host and enter to 
the chroot only to run the generated Makefile.

-- 
Manuel Canales Esparcia
Usuario de LFS nº2886:       http://www.linuxfromscratch.org
LFS en castellano: http://www.escomposlinux.org/lfs-es http://www.lfs-es.info
TLDP-ES:                           http://es.tldp.org



More information about the alfs-discuss mailing list