glibc bug in LFS-6.1 and its nALFS profile

Jeremy Huntwork jhuntwork at linuxfromscratch.org
Thu Oct 6 04:56:37 PDT 2005


Alexander E. Patrakov wrote:
> Tough question. The problem while Jeremy Huntwork was the project leader 
> was that exactly the same versions of packages had to be used in the 
> book and on the LiveCD (with the exception of ncurses because of "xterm 
> -lc" compatibility needed for i18n purposes). I'd rather ask Justin to 
> build the 6.1-4 CD with the following fixes:

I still feel very strongly that released versions of the LiveCD should 
follow as closely as possible the LFS book that they are based upon. 
Their first and main purpose is to successfully build *that* version of 
the LFS book. Any other use is secondary. The change to ncurses on those 
CDs was negligible as far as how it affected the rest of the system, so 
I OK'd that change.

If you want a CD that fixes this particular bug, then IMO, it's time to 
release a 6.2-pre1 CD. (Is 6.2 the next planned LFS version?) We've 
gotten past most of the bugs we were hitting in the LiveCD trunk 
scripts, so I think now is a good time to release.

--
JH

P.S. Make sure that the nALFS-profile that is included on the 6.2-pre1 
CD is based on LFS trunk and not 6.1



More information about the alfs-discuss mailing list