nALFS bug?: build fails because of optional package

Alex Prinsier aphexer at mailhaven.com
Sat Mar 5 08:01:59 PST 2005


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I'm trying to install Linux-PAM.

Manually it works all fine, but using nALFS to build it i saw some
strange things:

In the BLFS profiles there is:
=>chapter04/linuxpam.xml
<packageinfo>
      <requires>
        <name>cracklib</name>
      </requires>
      <utilizes>
        <name>db</name>
      </utilizes>
</packageinfo>

So even if db is missing, it should compile.

I start the compilation of Linux-PAM and i get this:

I: Log file stored in:
I: /root/.nALFS/packages/linuxpam-0.78.xml
W: Utilized package missing: db
E: Some required packages are missing; build aborted.
E: Execution failed (255).

It fails because it misses db? After that I installed db but it didn't
make any difference...

This comes from the log:
<single_try>
  <name>linuxpam</name>
  <version>0.78</version>
  <package mode="start">Sat, 05 Mar 2005 17:45:54 +0100</package>
  <handler_action>Some required packages are missing; build
aborted.</handler_action>
  <package mode="end" status="failed">Sat, 05 Mar 2005 17:45:54
+0100</package>
</single_try>

Some more info:

root at lfs:~# whoami
root
root at lfs:~# ls -al ~/.nALFSrc
ls: /root/.nALFSrc: No such file or directory
root at lfs:~# echo $HOME
/root
root at lfs:~# ls -al /root/.nALFS/stamps/
total 8
drwxr-xr-x  2 root root 4096 Feb 27 16:00 .
drwx------  4 root root 4096 Mar  2 19:54 ..
root at lfs:~#

Shouldn't nALFS create files in the stamps directory? It's empty...

I hope someone can help me out here.

Regards,

Alex Prinsier
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.0 (MingW32)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org

iD8DBQFCKdf3rCFWJqEhh1cRAlofAJ4romLJehaGQflSYkGqmHxQ8OGDaQCeOXPf
v6L8QkoVQY3Xd6e9fWiIK/0=
=sIMx
-----END PGP SIGNATURE-----



More information about the alfs-discuss mailing list