Help - Newbie

Jeremy Huntwork jhuntwork at linuxfromscratch.org
Mon Feb 28 13:25:02 PST 2005


cvrancken at mailcan.com wrote:
> Hi. I just downloaded the LFS 6.0 Live CD. Having installed LFS (5.1)
> before, now I want to go ahead and use the ALFS profile included in the
> CD. But I'm a little lost.
> 
> I just don't find clear instructions on how to do it. When does the
> profile start? When I run ./runit and expand the LFS.xml, I can see it
> contains Chapters 5 through 9. Should I follow the book up to Chapter 5,
> and then run the profile? (do I have to create the $LFS variable, for
> instance?)

No. The actual build (like in the book) starts at Chapter 5. It's named 
that way in the profiles for the sake of consistency. After you've got 
all the config file set up, then just start running the build from 
chapter 5.

> The ALFSprofile README talks about doing the following also before
> running the profile:
> 1) producing a kernel .config file
>       How am I supposed to do this? do I have to extract the kernel from
>       the packages directory into a temp directory, configure the kernel
>       and get the generated config file?

Yep. Make sure that your temp directory is located on your hd and 
mounted to the tree, otherwise you'll be writing directly to your RAM.

> 2) Customizing the files in the 'config' directory
>       It mentions several files: general.ent , fstab.xml , kernel.xml ,
>       grub.xml , keymap-ch6.xml , keymap-ch8.xml, console.xml . What
>       exactly should I modify, and how?

For the profile included with the livecd, most of that stuff is set up 
correctly already. You'll want to concern yourself mainly with 
general.ent, and either configure grub.xml, or configure grub manually 
(which is what I would recommend) after the ALFS build is done.

> Also, before even starting, I wanted to download the latest ALFS profile
> using wget. Of course, when I run net-setup from the livecd, I get a
> message saying : "Device eth0 is not present on this system!" . I do
> have a network connection that works otherwise when I boot with my host
> linux version. (Fedora Core 2). What can I do?

1) The 6.0 livecd can't by default build anything other than LFS 6.0 - 
there is a known bug with it. If you want to build a more recent version 
of LFS use the pre2 cd. Or, you could use the 6.0 cd but with the first 
two passes of binutils, build them dynamically instead of statically 
(Drop the flags about static)

2) Are you running net-setup as root? If so, and you still get that 
message, run lsmod and see what modules are loaded. If the module for 
your interface isn't loaded, use modprobe to load the correct one. I 
have a feeling this might be another instance of hotplug choosing the 
wrong 8139 dripc	S If so, the correct driver is probably 8139too.

--
Jeremy H.



More information about the alfs-discuss mailing list