XIncludes Halted (Segfault) :(

Thomas Pegg thomasp at linuxfromscratch.org
Thu May 27 20:43:50 PDT 2004


On Thu, 2004-05-27 at 22:29, Kevin P. Fleming wrote:
> Thomas Pegg wrote:
> 
> > And 2.6.10 did no good. :(
> 
> Yep, I see that here too. I've got it in the debugger, and what's 
> happening is that there are entity references not being replaced like 
> they are supposed to be. The fault is actually happening in 
> chapter05/creatingtoolsdir.xml, here:
> 
> {mkdir base="&LFS;"}
>    {option}parents{/option}
>     ...
> {/mkdir}

Dang, they never fixed the bug, grrrrr.
This was one thing that was plauging newxml devlopment a while back,
although I thought it was fixed in the recent versions but I guess not.

> 
> And the problem is that libxml2 is returning an entity reference for the 
> &LFS; reference, instead of substituting the entity value like it's 
> supposed to do. However, if I load that file directly into nALFS (not as 
> part of LFS.xml) it works fine, so somehow the XInclude is affecting it.
-- 
Thomas 
LFS User : 4729 
Linux User : 298329 
warpcore - 22:43:48 up 2 days, 10:53, 1 user, load average: 0.01, 0.09,
0.21
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
URL: <http://lists.linuxfromscratch.org/pipermail/alfs-discuss/attachments/20040527/f8f9bfec/attachment.sig>


More information about the alfs-discuss mailing list