Errors in current CVS LFS profiles ?

Dave Mascall nospamthanks at FOADSPAMMERS.mascall.net
Thu Mar 11 08:32:16 PST 2004


Hi

Just tried to do a build with the current CVS profile and found the
following problems with a few items.

As far as I am aware the latest checkout from cvs worked ok and so I should
have the latest versions of the LFS profile files.


Chapter 6 proc.xml - fails to mount /proc or /dev/pts

Needs &LFS; adding in the param statement to reference &LFS;/proc and
&LFS;/dev/pts.

I think this error was probably introduced when the mounting was moved to
before entering chroot. The current version would work IN the chroot but
fails outside chroot as its trying to mount in the original system ?


Chapter 6 makedev.xml - fails trying to change permissions

Needs the <name> tag changed to /dev/make_devices

It currently picks up the name from the entity &make-devices-file in
package.ent. This assumes that the name of the file is
make_devices-versionnumber. Its not - its just make_devices. Suggest change
is made to makedev.xml to hardcode /dev/make_devices as this a) matches the
book and b) matches what was done a few lines above it in the <copy> section
for <destination>


Package.ent and man-pages-1.66 - fails on the md5sum given.

Both wget.lfs.urls and package.ent specify man-pages-1.66.tar.bz2. But in
package.ent (config_seperate) the man-pages-md5 is for man-pages-1.66.tar.gz
! It currently starts "4045.... and it should start "dd510.... Suggest
package.ent is changed to give the md5 value for the bz2 version.


Chapter06 kernel.xml - copy to /usr/include/asm fails

Not altogether sure why it fails, but it appears that the dir "asm" does not
exist in /usr/include and I got round the problem by manually creating
/usr/include/asm and then restarting from that point within nALFS. The
problem may be caused by the fact that the copy statement for"asm" is
different that the following ones for "asm-generic" and "linux" which both
appear to work ok ?


config_seperate/kernel.xml - kernel build fails totally

Because the source has not been unpacked to /usr/src ! I think in chapter05
kernel-headers.xml the source is now unpacked under tools rather than
&LFS/usr/src. Therefore its not under /usr/src later on. Best fixed by
adding an unpack section to config_seperate/kernel.xml ?

Not sure if these have already been spotted or not - hope this helps :-)

Dave Mascall





More information about the alfs-discuss mailing list