trying to get 5.1.1 downloaded...

Roger Merchberger zmerch at 30below.com
Tue Jun 8 09:44:57 PDT 2004


Rumor has it that Kevin P. Fleming may have mentioned these words:
>Roger Merchberger wrote:
>
>>it contains some (but not all) of the schtuff that the nALFS 5.1.1 script 
>>needs, and same with the tarball -- however, the nALFS script is dying 
>>horribly trying to copy a file called:
>>"linux-config"  (sans quotes)
>
>Did you read any of the comments in the general.ent file that you edited 
>to configure your build? That entry is listed there, along with its purpose.

Actually, no - I've been doing the editing in nALFS itself, so I did not 
know there were comments in the general.ent file. I will look there, and 
see what's what.

>You are confusing LFS and nALFS in all of your messages.

My apologies -- I've only started using nALFS a couple of days ago...

>  It's very confusing, and will only serve to confuse other readers 
> (especially newbies)...

Like Me!

>  Please try to keep the terminology straight:
>
>- there are no "nALFS scripts", there are LFS profiles that can be used 
>with any ALFS tool; the nALFS tarball happens to include an LFS profile, 
>but there is not particular need to use that one instead of any other
>
>- there is no "5.0" or "5.1.1" nALFS at all; the nALFS-1.2.2 tarball 
>includes an LFS-5.0 profile, and the nALFS-1.2.3 includes an LFS-5.1.1 profile

Okay -- I'll do my best to keep that straight.

>>As such, once I finally get everything on the same sheet of music, I'll 
>>be making a tarball of both the nALFS script & all of the required 
>>packages, so it should be as simple as "untar, compile nALFS if 
>>necessary, and start running."
>
>It's already that simple. If you used the config_tarball directory as your 
>configuration for the LFS profile, and it did not match the contents of 
>the official LFS-5.1.1 tarball, then we need to know _exactly_ what did 
>not match (not just "it's missing some schtuff").

I didn't realize this was actively maintained, so I will restructure my 
quest of "reconfiguring it to work for me" to "report what didn't work and 
why to help others."

>  From your first message, it appears that you tried to use the 
> config_seperate directory, but use the tarball of packages, and that 
> won't work, because the tarball contains recompressed versions of all 
> packages that are not distributed in .bz2 form.

Not quite. I used the config_seperate directory, with the files that I 
obtained from the wget script, but one file was missing (wget didn't yell 
at me, but that's no proof it worked perfectly...) so that file I pulled 
from the tarball.

[[ Altho I did try exactly what you did say, it died horribly, and I of 
course assumed that was all my fault... ;-) ]]

>  That is why the LFS profile contains two config directories, and why the 
> README file tells you which one to use.
>
>If the wget script included in the LFS 5.1.1 profile did not obtain the 
>proper files to match the config_seperate directory, again we need to know 
>_exactly_ what did not match. Without that information we cannot correct 
>anything that might be wrong, and it's very difficult to help you. You 
>seem to have already spent a great deal of time trying to solve problems 
>that should not even exist, if the instructions included with nALFS and 
>the LFS profile are followed.

I'll re-unpack everything into fresh directories, run it and report exactly 
what's missing & whatnot.

Thanks,
Roger "Merch" Merchberger

--
Roger "Merch" Merchberger -- sysadmin, Iceberg Computers
zmerch at 30below.com

What do you do when Life gives you lemons,
and you don't *like* lemonade?????????????




More information about the alfs-discuss mailing list