trying to get 5.1.1 downloaded...

Kevin P. Fleming kpfleming at linuxfromscratch.org
Tue Jun 8 09:01:39 PDT 2004


Roger Merchberger wrote:

> it contains some (but not all) of the schtuff that the nALFS 5.1.1 
> script needs, and same with the tarball -- however, the nALFS script is 
> dying horribly trying to copy a file called:
> 
> "linux-config"  (sans quotes)

Did you read any of the comments in the general.ent file that you edited 
to configure your build? That entry is listed there, along with its purpose.

> which seems to be neither in the tarball nor the wget script. Is it 
> needed (I didn't see any reference to it in other 5.0 nALFS scripts I've 
> worked with so far) and I'm wondering if it's just a typo...

You are confusing LFS and nALFS in all of your messages. It's very 
confusing, and will only serve to confuse other readers (especially 
newbies). Please try to keep the terminology straight:

- there are no "nALFS scripts", there are LFS profiles that can be used 
with any ALFS tool; the nALFS tarball happens to include an LFS profile, 
but there is not particular need to use that one instead of any other

- there is no "5.0" or "5.1.1" nALFS at all; the nALFS-1.2.2 tarball 
includes an LFS-5.0 profile, and the nALFS-1.2.3 includes an LFS-5.1.1 
profile

> As such, once I finally get everything on the same sheet of music, I'll 
> be making a tarball of both the nALFS script & all of the required 
> packages, so it should be as simple as "untar, compile nALFS if 
> necessary, and start running."

It's already that simple. If you used the config_tarball directory as 
your configuration for the LFS profile, and it did not match the 
contents of the official LFS-5.1.1 tarball, then we need to know 
_exactly_ what did not match (not just "it's missing some schtuff"). 
 From your first message, it appears that you tried to use the 
config_seperate directory, but use the tarball of packages, and that 
won't work, because the tarball contains recompressed versions of all 
packages that are not distributed in .bz2 form. That is why the LFS 
profile contains two config directories, and why the README file tells 
you which one to use.

If the wget script included in the LFS 5.1.1 profile did not obtain the 
proper files to match the config_seperate directory, again we need to 
know _exactly_ what did not match. Without that information we cannot 
correct anything that might be wrong, and it's very difficult to help 
you. You seem to have already spent a great deal of time trying to solve 
problems that should not even exist, if the instructions included with 
nALFS and the LFS profile are followed.




More information about the alfs-discuss mailing list