Wrong md5 digest of archive

Dieter Raith raith at hlrs.de
Thu Jul 22 09:51:05 PDT 2004


I try to create LFS-5.1.1 with nALFS version 1.2.4 and libxml2 version 
2.6.11.
I created nALFS and libxml2 from source. I must admit that there were 
older versions of these, but
/usr/local/lib and /usr/local/lib/nALFS look good in terms of the 
creation date.
Now I get this:

<?xml version="1.0"?>
<package_log>
  <single_try>
  <name>binutils-pass1</name>
  <version>2.14</version>
  <package mode="start">Thu, 22 Jul 2004 17:38:03 +0200</package>
  <stage mode="start">Thu, 22 Jul 2004 17:38:03 +0200</stage>
  <handler_action>Wrong md5 digest of archive: 
/tools/packages-5.1.1/binutils-2.14.tar.bz2</handler_action>
  <stage mode="end" status="failed">Thu, 22 Jul 2004 17:38:03 +0200</stage>
  <package mode="end" status="failed">Thu, 22 Jul 2004 17:38:03 
+0200</package>
</single_try>

package.ent:
<!ENTITY binutils-md5 "2da8def15d28af3ec6af0982709ae90a">
<!ENTITY binutils-version "2.14">
<!ENTITY binutils-package "binutils-&binutils-version;.tar.bz2">
<!ENTITY binutils-directory "binutils-&binutils-version;">

md5sum /mnt/lfs/tools/packages-5.1.1/binutils-2.14.tar.bz2 
reports
2da8def15d28af3ec6af0982709ae90a  
/mnt/lfs/tools/packages-5.1.1/binutils-2.14.tar.bz2
which seems exactly what we are looking for.
So what is wrong here.

Rgds
Dieter








More information about the alfs-discuss mailing list