Running nALFS freezes the machine

Chris Martin cmartin at spamcop.net
Fri Jan 23 02:34:51 PST 2004


[Sorry this is long, I have tried to provide information which seems
relevant.]

It happened with 1.2.0 and also with 1.1.8. It is now happening with
1.2.1 too.

The machines:

   addedvalue: dual Pentium III 600 MHz, 512 Mb RAM
   futureperfect: Athlon 1.4 GHz, 512 MB RAM
   greyarea: Athlon XP 1600+, 512 Mb RAM

At first it seemed that the old LFS system might be to blame (3.1 on
addedvalue and futureperfect, 4.1 on greyarea) -- perhaps an upgrade
too far (GCC 3.2.2? kernel compiled using gcc-3.2.2?) and a small
installation of SuSE 9.0 was put on a spare partition on each machine
and nALFS 1.2.0 run from that.

It worked in every case and the 5.0 installations on addedvalue and
futureperfect are in daily use without problems (touch wood!).

The installation on greyarea was copied (tar) to a 1Gb partition
(hda1, ext3) and libxml2-2.5.11 and nALFS-1.2.1 installed.

The target for a new installation on greyarea was a set of partitions:

/dev/hda5  /mnt/lfs
/dev/hda7  /mnt/lfs/usr
/dev/hda8  /mnt/lfs/usr/src
/dev/hda9  /mnt/lfs/home
/dev/hda10 /mnt/lfs/home/iso
/dev/hda11 /mnt/lfs/opt
/dev/hda12 /mnt/lfs/var

all ext3.

The first try failed in /tools:binutils as hda5 was 1Gb which wasn't
enough for the /tools directory.

A second try (running mkfs.ext3 again on each partition) with hda10 (2
Gb) as root failed freezing the machine -- no keyboard, blank screen,
no remote login -- the same behaviour as before.

Comparing the nALFS compilations (both 1.2.1) under SuSE and LFS 5.0,
the object files are different sizes. SuSE's Glibc is version 2.3.2-88
and its GCC is 3.3.1-24.

I am at a loss to see what to do next -- other than run it under SuSE
again: I will happily provide more information or run debugging under
instruction if there is any interest in finding out more.



More information about the alfs-discuss mailing list