Problem with nALFS 1.2.1

Thomas Pegg thomasp at linuxfromscratch.org
Sat Jan 17 18:28:57 PST 2004


On Sat, 2004-01-17 at 19:30, Alex Potter wrote:
> For some reason, configure appears to be trying to write to root's home
> directory during the build. Have I missed some small but vital step?
> 
> I: Using "/root/.nALFS" directory.
> I: Using libxml2, version 2.6.4.
> I: Loading handlers from /usr/local/lib/nALFS.
> I: Total 38 handlers loaded.
> I: Total 32 parameters found.
> I: Parsing LFS-5.0.xml...
> I: Profile added:
> /home/alexp/Documents/nALFS-1.2.1/profile/LFS-5.0-3/LFS-5.0.xml
> I: Using "/root/.nALFS/nalfs.log" for status logging.
> I: For help, type '?'.
> I: Run (m)arked elements, element and it's (c)hildren, element's children
> I: and (n)ext elements, or (f)orce running of current element? 
> I: 
> I: Starting execution of marked elements...
> I: 
> I: Creating directory in / (parents): /mnt/lfs/tools
> I: Creating symbolic link in / (force): /
> I:     /mnt/lfs/tools
> I: Creating directory in /mnt/lfs (parents): /mnt/lfs/tools/packages-5.0
> I: Creating directory in /mnt/lfs (parents): /mnt/lfs/tools/build
> I: Executing in /:
> I:     cp /root/sources/* /mnt/lfs/tools/packages-5.0
Try moving your sources to somewhere other than root's home directory.

> I: Executing system command in /:
> I:     id -u lfs &> /dev/null || useradd -s /bin/bash -m lfs
> I: Executing system command in /:
> I:     echo lfs:rabbit | chpasswd
> I: Changing user ownership to lfs (recursive) in /: /mnt/lfs/tools
> I: Changing to user "lfs".
> I: Creating new file in /: /home/lfs/.bash_profile
> I: Changing to user "lfs".
> I: Setting environment variable LFS:
> I:     /mnt/lfs
> I: Setting environment variable LC_ALL:
> I:     POSIX
> I: Prepending to environment variable PATH:
> I:     /tools/bin:
> I: Unsetting environment variable CFLAGS.
> I: Unsetting environment variable CXXFLAGS.
> I: Unsetting environment variable CC.
> I: Unsetting environment variable CXX.
> I: Unsetting environment variable CPP.
> I: Unsetting environment variable LD_LIBRARY_PATH.
> I: Unsetting environment variable LD_PRELOAD.
> I: Digest ok.
> I: Unpacking /tools/packages-5.0/binutils-2.14.tar.bz2...
> -: binutils-2.14/binutils/doc/Makefile.am
> 
> Snipped unpacking
> 
> -: binutils-2.14/texinfo/texinfo.tex
> -: binutils-2.14/md5.sum
> I: Done unpacking /tools/packages-5.0/binutils-2.14.tar.bz2.
> I: Creating directory in /tools/build (parents): binutils-build
> I: Unsetting environment variable CFLAGS.
> I: Unsetting environment variable CXXFLAGS.
> I: Executing in /tools/build/binutils-build:
> I:     ../binutils-2.14/configure --prefix=/tools --disable-nls
> -: creating cache ./config.cache
> -: checking host system type... mkdir: cannot create directory
> `/root/tmp/cg4727-23223': Permission denied
> -: config.guess: cannot create a temporary directory in /root/tmp
> -: configure: error: can not guess host type; you must specify one
> I: Log file stored in:
> I: /root/.nALFS/packages/binutils-pass1-2.14.xml
> E: Execution failed (1).
> I: Total time executing: 00:00:00
Hmmmm, that shouldn't be happening, unfortunately I can't reproduce the
problem. 
> 
> -- 
> Regards
> Alex
> The email address above is a spamtrap.
> Please reply to alexp[AT]apcuk[DOT]dyndns[DOT]org
-- 
Thomas
LFS User : 4729
Linux User : 298329



More information about the alfs-discuss mailing list