Package version number comparisons (for conditional logic)

Jamie Bennett jamie at linuxfromscratch.org
Sat Feb 7 13:10:11 PST 2004


On Sat, 2004-02-07 at 17:32, Kevin P. Fleming wrote:
> After thinking about this for a few days, I'm not happy with 
> implementing the version number comparisons as detailed in the current 
> syntax document. Specifically, it would annoy me greatly if my profiles 
> did not consider version "2.0.10" to be greater than "2.0.9".

> Anyone have any objections?

No, but I suppose we cannot cater for every naming convention of every
package, I'm sure we will miss something ;)

...
Jamie Bennett		-	jamie at linuxfromscratch dot org




More information about the alfs-discuss mailing list