LFS-SVN profile

Daniel S. Reichenbach dsr at best-off.org
Wed Dec 29 02:14:47 PST 2004


Hi,

I have downloaded the latest LFS-SVN profile and updated it for the
current unstable LFS book and now I ran into a strange error.

binutils have been updated to 2.15.94.0.2.

When running the pass 1 for binutils in chapter 5, namely this:

I:      make  LDFLAGS="-all-static"

configure returns an error:
-: checking for library containing dlopen... configure: error: Link
tests are not allowed after GCC_NO_EXECUTABLES.
-: make: *** [configure-libiberty] Error 1

Now when I run the commands for binutils on the command line, this
error does not appear and the build succeeds. Any hints?

My build host is running RHEL 4 beta 2, which is like Fedora Core 3.

Daniel S. Reichenbach
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: Dies ist ein digital signierter Nachrichtenteil
URL: <http://lists.linuxfromscratch.org/pipermail/alfs-discuss/attachments/20041229/a0d915c2/attachment.sig>


More information about the alfs-discuss mailing list