where do i post (maybe not so) stupid newbie question about nALFS?

chief_wrench oq at hirsa.de
Fri Nov 28 16:49:00 PST 2003


hello everyone,
see subject...

there seems to be no forum etc focussing on nALFS, this is the closest i can get.

ah well, i´ll ask anyway, you may flame me.

- i downloaded pretty recent versions of nALFS, lfs 5.0 profiles and tarball.
- after editing config/general.ent i did "*", "s", "m".
- re-checked general.ent while compiling, found some configuration error of mine, cancelled the build process with "S".
- corrected error, "R"eloaded the configuration, started compiling again.
- when it comes to binutils stage 1, i get the following error message:
<----snip--->
x-: /lib/libc.so.6: undefined reference to `_dl_lookup_symbol at GLIBC_PRIVATE'   x
x-: /lib/libc.so.6: undefined reference to `_dl_map_object at GLIBC_PRIVATE'      x
x-: collect2: ld returned 1 exit status                                        x
x-: *** The comma                                                              x
xI: Log file stored in "/root/.nALFS/packages/binutils-pass1-2.14.log".nd 'gcc x
x-o conftest -g -O2   conftest.c' failed.                                      x
x-: *** You must set the environment variable CC to a working compiler.        x
xI: Sending the package log to the frontend...                                 x
xE: Execution failed (1).     

at some stage of the book before, the env.variable cc is explicitly unset.

is it a bug? is it a feature?

thanks for reading (and answering maybe)
oliver



More information about the alfs-discuss mailing list