environment help

James Robertson jameswrobertson at earthlink.net
Mon Aug 11 20:13:52 PDT 2003


Neven Has wrote:

> On Mon, Jul 21, 2003 at 09:52:03AM -0500, James Robertson wrote:
> 
>>The above fix, helps with my glibc problem. I however am still confused 
>>on how nALFS handles the environment tags.  If I echo variables (e.g. 
>>echo $PATH), I get expected results.  It is just when I want to see the 
>>whole environment that the lfs user is running in that I have issues.
> 
> 
> I played a bit with executing "env" in various places, but I can't
> seem to find anything unusual myself.  Can you post a sample profile
> illustrating the problem?
> 
> 
> Neven
> 
Here is my working profile.  The problem occurs if you add a <execute 
command="env"> command in phase2/phase2.xml.  You can see the other 
ones.  They all work as expected.

James
-- 
---------------------------------------------------------
James Robertson | jameswrobertson at earthlink dot net
---------------------------------------------------------
Reg. Linux User: #160424  http://counter.li.org
Reg. LFS User:   #6981    http://www.linuxfromscratch.org
---------------------------------------------------------

-------------- next part --------------
A non-text attachment was scrubbed...
Name: jlfs-profile.tar.bz2
Type: application/x-bzip2
Size: 14105 bytes
Desc: not available
URL: <http://lists.linuxfromscratch.org/pipermail/alfs-discuss/attachments/20030811/33f50ff2/attachment.bin>


More information about the alfs-discuss mailing list