nALFS sometimes doesn't pick up changed/added files

Gerard Beekmans gerard at linuxfromscratch.org
Fri Oct 18 16:18:56 PDT 2002


On October 18, 2002 02:37 pm, Neven Has wrote:
> Can you somehow reproduce that for sure? Maybe with a small profile, as
> an example?

I think I have found something here and I've been able to reproduce it. It's 
not a profile matter, it's how I execute a profile: step by step

Here's an example. Say I open a package profile such as bin86. 

* In nALFS I highlight it and click on the right arrow key to expand it.
* I highlight the next element in the list "Enter stage: Unpacking a package."
* I run its children by hitting "s" "c"
* I go to the next element in the list "Enter stage: Installing a package."
* I run it too by hitting "s" "c"
* I go to the next element in the list "Enter stage: Clean-up."
* I run it by hitting "s" "c"

It's done now and nALFS reports that installed files are stored in 
/path/to/file/bin86.files.xxxxxx and that's an empty file.

* Now, I go back to the parent, the element marked "Package bin86 0.16.3"
* I unmark it by hitting "m" "n"
* I run the entire thing by hitting "s" "c"

Done again, the file now created by nALFS is a proper file.

So something goes wrong when I do it step-by-step. Usually I also open more 
sub-element like the ones under "Installing a package" so I can run the 
various <make> and <copy> and whatever a package has one-by-one and manually 
do some checking. The end result is that a package element is completely 
finished and nALFS marks it as such with "#" symbols but the installed files 
list is now always empty unless nALFS does it all in a row.

I hope this is enough information for you to do something with?

-- 
Gerard Beekmans
www.linuxfromscratch.org

-*- If Linux doesn't have the solution, you have the wrong problem -*-
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe alfs-discuss' in the subject header of the message



More information about the alfs-discuss mailing list