checksum verification in nALFS

Neven Has haski at sezampro.yu
Tue Oct 15 09:45:19 PDT 2002


On Mon, Oct 14, 2002 at 05:51:03PM +0100, Mark Ellis wrote:
> On 2002.10.13 19:29 Vassili Dzuba wrote:
> > Let's assume that a get a new BLFS profile and that i want to update
> > only one or two packages. I can load it into nALFS, choose
> > interactively the package i want to build, and type 's', 'c'. But if
> > the validation of the checksum is performed at the beginning of the
> > profile, it will not be done here.

Right, but I'm not sure if that's something we should worry about? I
just mentioned those actions at the beginning of the profile as an
example of something that could be done. However, I think that this is
more a problem for a profile writer. For example, one can also put that
checking right above the unpack, so it would be inside the <package>.

> >     <alfs version="3.0">
> > 
> >         <digest type="md5">
> >              <path>&packages_dir;/&bash_package;</path>
> >              <value>&bash_md5</value>
> >         </digest>
> > 
> >         ....
> >             <unpack>
> >                  <archive>&packages_dir;/&bash_package;</path>
> >                  <destination>&build_dir</destination>
> >             </unpack>
> >      ...
> >      </alfs>

Hmm,  I'm not sure. I don't think I like parser having to remember
anything like this. Just because of:

> Some of this is i think getting overly complex because the operation
> of the backend is being tied too closely to the syntax.

It's much too tied to the syntax, and if we want to have a different
parsers (and we do) it would be annoying for programmers and not really
that clear.

It wouldn't be just "profile's syntax" all that they need any more, it
would be some special behavior in some special cases which would have to
be enforced. (Yes, this can be optional, but still...).

> A specific instruction to check archive integrity should _not_ be a
> part of the syntax, only the information to enable it to do so.

That brings us back the that first proposed syntax which can be used for
that. :)

So maybe we should implement it like that after all, at least for now.
If we were to add something more complicated, the syntax should have to
be changed anyway, so we don't have to hurry with decisions.

And I'm also out of ideas (I'm writing this message for two days now,
constantly changing my mind :).


Neven

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe alfs-discuss' in the subject header of the message



More information about the alfs-discuss mailing list