Installing nALFS on LFS

Lee Saferite lee.saferite at internet.lu
Mon May 6 01:39:49 PDT 2002


Neven,

   Why are you using xml2-config?  just use the autoconf macros that use
pkg-config.

  
PKG_CHECK_MODULES(VARIABLEBASE,MODULELIST[,ACTION-IF-FOUND,[ACTION-IF-N
OT-FOUND]])

   if you set the 'VARIABLEBASE' to XML2 then you end up with
XML2_CFLAGS and XML2_LIBS.   I know it adds ANOTHER dependency, but
using pkg-config as opposed to seperate *-config programs seems better,
it helps promote a standard.

On Sun, 5 May 2002 15:57:54 +0200
Neven Has <haski at sezampro.yu> wrote:

> On Sun, May 05, 2002 at 09:59:00PM +1000, DaRK wrote:
> > i've been trying to install nALFS on my LFS it installs fine on
> > slackware and runs and all but on lfs it says when i do ./configure
> > i need libxml2 i have gotten that installed and all but still don't
> > seem to work is there anything else i need or something special i
> > need to do ?
> 
> configure tries to find "xml2-config" program in PREFIX/bin directory
> (if specified with --with-libxml2=PREFIX) and then in your PATH.
> 
> Make sure you have it in there.
> 
> And let me know if you solved the problem, since this is my first shot
> at Autoconf. :)
> 
> Thanks,
> 
> Neven
> 
> -- 
> Unsubscribe: send email to listar at linuxfromscratch.org
> and put 'unsubscribe alfs-discuss' in the subject header of the
> message
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe alfs-discuss' in the subject header of the message



More information about the alfs-discuss mailing list