Brainstorm: <stage>

Neven Has haski at sezampro.yu
Sun Mar 31 02:51:02 PST 2002

On Sat, Mar 30, 2002 at 09:36:09AM +0100, Lee Saferite wrote:
> > > <stage>
> > >    <stageinfo>
> > 
> > Maybe we should use just <info> here? This element will _always_ be
> > right after <stage>, so it looks a bit unnecessary to use <stageinfo>?
> > And also, concatenating two different words like that, without any
> > separator, or at least a capital letter is a bit ugly too?
> Well, I was under the impresssion we couldn't have two 'different'
> elements with the same name.  the element for <package> and <stage>
> would contain different info, no?

Well yes, but <info> would be just a container, a parent element
grouping other elements. So it's different, I think.

But I'm fine with <stageinfo> too, I don't find this that important issue.

> > I'll vote for <environment> here. It's a long word, but IMO, much more
> > descriptive and nicer.
> > 
> > Also, I think that we need a default mode for it. Simple setting for
> > example? And then mode="add" (or "append" ?) to override the default.
> I agree, the long name is better. and I just forgot to specify a
> default.  I would think the best one is add. (or append)

Mark was also going for that, which makes the score 2:1 for append. ;)

I was suggesting simple setting since it's a more basic operation - a
simple VAR=value. With appending, you have to do VAR=$VARvalue which
is another step and more typing, so I though it would be somehow
natural to make the user have to add mode="append" for that, to correspond
to it, in a way.

Also, a simple setting of the variables is used more in LFS (still,
I think), which shouldn't be a big "decider" (can't find a better word :),
but should be considered IMO.


Unsubscribe: send email to listar at
and put 'unsubscribe alfs-discuss' in the subject header of the message

More information about the alfs-discuss mailing list