Brainstorm: <stage>

Mark Ellis mark.uzumati at virgin.net
Fri Mar 29 07:32:54 PST 2002


On 2002.03.29 14:07 Neven Has wrote:
> On Fri, Mar 29, 2002 at 02:20:36PM +0100, Lee Saferite wrote:
> > <stage>
> >    <stageinfo>
> 
> Maybe we should use just <info> here? This element will _always_ be
> right
> after <stage>, so it looks a bit unnecessary to use <stageinfo>?
> And also, concatenating two different words like that, without any
> separator, or at least a capital letter is a bit ugly too?
> 

Might be nice, having <info> for our 2 major containers, <stage> and 
<package>.

> >       <name/>
> >       <base/>
> >       <chroot/>
> 
> This <base> is relative to <chroot> (if any), I assume?
> 
> >       <user/>
> >       <group/>
> 
> I would leave out the <group> here, at least for now. I think it's
> better
> that we go with a simple su-like implementation (again - for now).
> 

Good point, dunno about you but i havent dealt with GIDs much, we could 
fla this one as "will be but not yet".

> >       <env mode="set|add">
> >          <variable name="" value=""/>
> >       </env>
> 
> I'll vote for <environment> here. It's a long word, but IMO, much more
> descriptive and nicer.
> 

Agreed.

> Also, I think that we need a default mode for it. Simple setting for
> example? And then mode="add" (or "append" ?) to override the default.
> 

I'd have gone for "add" as the default, but hey :)

> >    </stageinfo>
> >    ... (any valid action elements, including <package> and <stage>)
> 
> I suppose it would be too much to add another "parent element" here,
> to
> include all these other elements, contained in <stage>.
> 

Might be nice, i could go either way on this.

> > </stage>
> 

Mark
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe alfs-discuss' in the subject header of the message



More information about the alfs-discuss mailing list