missing libxml2.so.2 ?

Yann E. MORIN yann.morin.1998 at anciens.enib.fr
Thu Dec 26 15:58:39 PST 2002


On Thursday 26 December 2002 23:48, you wrote:
 > Installation of aLFS worked very well, but on running aLFS
 > profiles/LFS/latest.xml (as mentioned in the README) my machine complains,
 > that libxml2.so.2 is missing. Of course it is installed on my system
 > (/usr/local/lib/libxml2.so.2) - so where does aLFS expect this file
 > (sorry, I didn't find any information concerning this problem) ? I think I
 > could solve this with a symbolic link. Or is this not just a problem of a
 > wrong path ?

In the first place, check if /usr/local/bin is listed in /etc/ld.so.conf.
If this is the case, run ldconfig, as suggested by Neven. If not, put it
there and re-run ldconfig again.

Next, try to soft-link the library (if the target does not exist yet) :
  ln -s libxml2.so.2 /usr/local/lib/libxml2.so

Third copy libxml2.so.2 as libxml2.so to the directory the nALFS binary is
placed, then to the directory you run the nALFS from. That won't tell you
what or where your problem lies, but that will have you on the road.

Oh, by the way, check the permissions on libxml2.so.2. It happened to me that
a .so was not world readable, and I couldn't run any binary dynamically linked
to it (fucking distro updater) !

Regards,
Yann.

-- 
.-----------------.--------------------.------------------.--------------------.
|  Yann E. MORIN  | Real-Time Embedded | /"\ ASCII RIBBON | Erics' conspiracy: |
| +0/33 662376056 | Software  Designer | \ / CAMPAIGN     |  ___               |
| --==< °_° >==-- °---.----------------:  X  AGAINST      |  \e/  There is no  |
| web: ymorin.free.fr | SETI at home  567 | / \ HTML MAIL    |   v   conspiracy.  |
°---------------------°----------------°------------------°--------------------°
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe alfs-discuss' in the subject header of the message



More information about the alfs-discuss mailing list