little problem here

Gerard Beekmans gerard at linuxfromscratch.org
Fri Jan 19 06:18:59 PST 2001


Hey,

Trying to install KDE from a profile Bryan gave me. It's working ok except 
for this minor problem:

=====[ Package: qt 2.2
Starting preconfigure
Starting move
Moving qt-2.2 from /home/gerard to /usr/kde/qt.
Moving qt-2.2 to /usr/kde/qt ...
================================================================================
error(move): Unable to move qt-2.2 to /usr/kde/qt: Invalid cross-device link
Element is in : preconfigure
Path          : /alfs/package/preconfigure/move
Full element  :
<move dir="/home/gerard" source="qt-2.2">/usr/kde/qt</move>
================================================================================ 

The section from the profile:

<alfs version="0.0.6">
 
<mkdir dir="/usr">kde</mkdir>
 
<package name="qt" version="2.2">
<preconfigure>
        <move dir="&builddir;" source="qt-2.2">/usr/kde/qt</move>
</preconfigure>

I'm suspecting a perl version problem. That box runs:
perl --version
 
This is perl, version 5.005_03 built for i386-linux                           

---

On a box with perl 5.6.0 it doesn't fail.

-- 
Gerard Beekmans
www.linuxfromscratch.org

-*- If Linux doesn't have the solution, you have the wrong problem -*-





More information about the alfs-discuss mailing list