ALFS.pm drawbacks

Nicholas Dille DarkYeti at gmx.net
Mon Feb 12 01:44:39 PST 2001


> > It would be nice if we could make it work with some older perl versions,
> > at least 5.00503, since there are a lot of people still using it.
>
> Agreed. I didn't want to introduce another requirement. Just happend...
> The main problem is Carp::Heavy, right? It's used by croak().
> Afaik, croak()
> isn't new in perl 5.6. I will take a look at the code, but I don't have
> an old perl around yet.

i am still using perl 5.005_03 on one of my boxes cause i didn't have the
time to update that system to lfs :-(

but for me it seems to work when i removed the line "use Carp/Heavy.pm"
i haven't done a test run without that line but it seems to be just fine.

hope that helps
nic.






More information about the alfs-discuss mailing list